Announcement

Collapse
No announcement yet.

!!!oil Leak!!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • !!!oil Leak!!!

    I recently rebuilt my 88 2.8l MPFI engine, i know that when you rebuild engines that they burn some oil. my problem is a actual leak. there is a sensor of some type (looks like a oil pressure sensor) that is mounted next to the cap where the distributor would go. it is leaking oil and is causing me to add half a quart of oil per day. what is the sensor? i have a 1989 block of the same engine, but it dosn't have a port for this sensor. is it nessesary to have? someone help me quick!

  • #2
    http://60degreev6.com/showthread.php...p+drive+o-ring

    Post 7 will lead you to a "How-To" on v6z24.com.
    -Brad-
    89 Mustang : Future 60V6 Power
    sigpic
    Follow the build -> http://www.3x00swap.com/index.php?page=mustang-blog

    Comment


    • #3
      no, that O-ring is not the problem, the sensor right next to it is though. like i said it looks like a oil pressure sensor, but isn't the oil pressure sensor located on the side of the block? i just need to know what the sensor is so i can replace it.

      Comment


      • #4
        I don't think I've ever seen a sensor in that area of the engine... Got a pic?
        -Brad-
        89 Mustang : Future 60V6 Power
        sigpic
        Follow the build -> http://www.3x00swap.com/index.php?page=mustang-blog

        Comment


        • #5
          Here is a picture I have of a 3100 and the oil pump drive, and there is no sensor even close to it...

          -Brad-
          89 Mustang : Future 60V6 Power
          sigpic
          Follow the build -> http://www.3x00swap.com/index.php?page=mustang-blog

          Comment


          • #6
            right, because your engine is newer, mine was made in 1987. yours probably uses a different computer. I saw another engine at the junk yard that had the same sensor, so it wasn't just a Quick Fix or anything, also it goes right into the wiring harness.
            in your picture the sensor would be coming out of the block at an angle on the flat right next to the front cylinder head.

            Comment


            • #7
              Hence the reason I asked for a picture...
              -Brad-
              89 Mustang : Future 60V6 Power
              sigpic
              Follow the build -> http://www.3x00swap.com/index.php?page=mustang-blog

              Comment


              • #8
                yeah, sorry i don't know how to upload or where to upload pics.

                Comment


                • #9
                  Hit the "Post Reply" button instead of using the Quick Reply.

                  Below the msg box, there are Additional Options, and then Attach Files. Hit the "Manage Attachments" button and browse for the file, then hit upload.
                  -Brad-
                  89 Mustang : Future 60V6 Power
                  sigpic
                  Follow the build -> http://www.3x00swap.com/index.php?page=mustang-blog

                  Comment


                  • #10
                    well i found that the sensor is actually a switch, i bought one today and installed it, so ill have to see tomorrow is it still leaks.

                    Comment


                    • #11
                      please, still take a pic of it and post it. im curious what this switch is. ive never heard of or seen it before, and my buddy had an 87 cavy and i have an 86 with gen 1 motor.

                      Comment


                      • #12
                        yeah same here i have about 5 or so 88 89 90 2.8 /3.1 and i never saw that senser there
                        01 olds shilluette 3400/4T65-E stock for now

                        Comment

                        Working...
                        X