Announcement

Collapse
No announcement yet.

3.4L/3400 Top End Swap

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Do they have the same connectors on them?

    Comment


    • #32
      I believe they are EV1, along with pretty much all LS injectors. I have a set of your interested. I just bought some LS EV1 injectors for my 01 V6 and bought delphi to EV1 adapters. If you need any help with anything let me know. I have become quite versed. I also have almost everything needed for a 3.4/3400/3500 hybrid of you wanted to go that route. Selling it cheap! 6166445482

      Sent from my Verizon LG G3 sexiness via tapatalk

      Comment


      • #33
        So almost all ls1 injectors use the ev1 connecters? The stock 3400 injectors are delphi connectors right? So if I went with EV1 I'd need that adapter?

        Comment


        • #34
          Originally posted by Robindehood View Post
          So almost all ls1 injectors use the ev1 connecters? The stock 3400 injectors are delphi connectors right? So if I went with EV1 I'd need that adapter?
          Correct mostly, all LT1 are EV1 and some LS1, depending on vehicle some were different. Like the corvettei think are EV6 for the newer years. Here's a pic of the differences and a link for adapters. http://www.casperselectronics.com/st...x.php?cPath=14 ATTACH]8391[/ATTACH]

          Sent from my Verizon LG G3 sexiness via tapatalk
          Attached Files

          Comment


          • #35
            I'm pretty sure most LS injectors ate Mikey multech II plugs
            '89 Firebird, 3500 Turbo, T56, 9-bolt/4.11
            '86 Fiero, 3500, 4-speed

            Comment


            • #36
              Originally posted by caffeine View Post
              I'm pretty sure most LS injectors ate Mikey multech II plugs
              The ones I just got are EV1

              Sent from my Verizon LG G3 sexiness via tapatalk

              Comment


              • #37
                I'm thinking that my best bet is going to be just to try and get a set of 28#'s to be safe

                Comment


                • #38
                  Also Caffeine, I lost your number when I got a new phone, shoot me a text man

                  Comment


                  • #39
                    Alright guys, not sure if this forum is still active but there's been progress. Car is in running condition. I say running condition because it ran well enough to drive onto a trailer, and since then we've had some hiccups. The car will run, but is really rough and rich and will sputter and die after 30 seconds. I've pulled the plugs each time and they seem to get black and carbon coated extremely quickly. Could it just be that the car is running too rich due to the 28# injectors and aluminum top end on the stock tune?

                    Comment

                    Working...
                    X